aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-03 08:58:14 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-03 08:58:14 +0000
commit8dc7ced4d4df85bc6cc77b625d54150a64f31bc6 (patch)
treee506b1895f22ee50f8e03e6806afc8384560e78a /include/kernel.mk
parente5e03321f9e942f75b8b150dc0bbdaba6b1c0c9b (diff)
downloadupstream-8dc7ced4d4df85bc6cc77b625d54150a64f31bc6.tar.gz
upstream-8dc7ced4d4df85bc6cc77b625d54150a64f31bc6.tar.bz2
upstream-8dc7ced4d4df85bc6cc77b625d54150a64f31bc6.zip
require all CONFIG_* symbols listed in its KCONFIG to be set to m in order to actually build a kmod package, tweak and fix kernel package definitions.
SVN-Revision: 8591
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 519ea42d23..a0f256b998 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -104,7 +104,8 @@ $(call KernelPackage/$(1)/description)
endef
endif
- ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
+ # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
+ ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install
mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)