aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-version.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-04-27 19:13:07 +0200
committerFelix Fietkau <nbd@nbd.name>2019-05-11 11:37:10 +0200
commit85017c40f4efce11edd77e0caac14aed0fd690eb (patch)
tree016be4bb6f80dcc9ef001a1c95424b8f3fba4cea /include/kernel-version.mk
parent9cb3a3255e024183a2e179fe6621cd11fa6b8670 (diff)
downloadupstream-85017c40f4efce11edd77e0caac14aed0fd690eb.tar.gz
upstream-85017c40f4efce11edd77e0caac14aed0fd690eb.tar.bz2
upstream-85017c40f4efce11edd77e0caac14aed0fd690eb.zip
build: add a config option for enabling a testing version of the target kernel
If the target supports a newer kernel version that is not used by default yet, it can be enabled with this option Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/kernel-version.mk')
-rw-r--r--include/kernel-version.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 81ec2bd252..c978294ecf 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,6 +2,10 @@
LINUX_RELEASE?=1
+ifdef CONFIG_TESTING_KERNEL
+ KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
+endif
+
LINUX_VERSION-4.9 = .172
LINUX_VERSION-4.14 = .115
LINUX_VERSION-4.19 = .38
@@ -23,6 +27,9 @@ else
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
endif
+ifdef KERNEL_TESTING_PATCHVER
+ LINUX_TESTING_VERSION:=$(KERNEL_TESTING_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_TESTING_PATCHVER)))
+endif
endif
split_version=$(subst ., ,$(1))