aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-version.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-25 09:12:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-25 09:12:57 +0000
commit35bccdd4baa9ee6378762ed5b16c01a2543d0dcc (patch)
tree851a3443f885fad99b4b029a99c49ac003bd2b48 /include/kernel-version.mk
parent216e8fcc55397c76a8bf1f1fe55432921be77519 (diff)
downloadupstream-35bccdd4baa9ee6378762ed5b16c01a2543d0dcc.tar.gz
upstream-35bccdd4baa9ee6378762ed5b16c01a2543d0dcc.tar.bz2
upstream-35bccdd4baa9ee6378762ed5b16c01a2543d0dcc.zip
store the default kernel version for our ports in a single place (target makefiles can still override it if necessary)
SVN-Revision: 5899
Diffstat (limited to 'include/kernel-version.mk')
-rw-r--r--include/kernel-version.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
new file mode 100644
index 0000000000..af457a2485
--- /dev/null
+++ b/include/kernel-version.mk
@@ -0,0 +1,15 @@
+# Use the default kernel version if the Makefile doesn't override it
+
+ifeq ($(LINUX_VERSION),)
+ ifeq ($(KERNEL),2.4)
+ LINUX_VERSION:=2.4.33.4
+ LINUX_RELEASE:=1
+ LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
+ else
+ LINUX_VERSION:=2.6.19.1
+ LINUX_RELEASE:=1
+ LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
+ endif
+endif
+KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+