aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-02-19 17:54:22 +0200
committerPaul Spooren <mail@aparcar.org>2022-03-29 13:32:31 +0100
commitdf2ae8826ced4f374bcb693b44d8a113ad150d70 (patch)
tree5a02f5343f5ab1021bb5857cbe50138c16f85487 /include/image.mk
parent34fb36e165d5b6e6e37d33b4b0da789a8f1430bb (diff)
downloadupstream-df2ae8826ced4f374bcb693b44d8a113ad150d70.tar.gz
upstream-df2ae8826ced4f374bcb693b44d8a113ad150d70.tar.bz2
upstream-df2ae8826ced4f374bcb693b44d8a113ad150d70.zip
image: let mksquashfs4 use all processors
Drop the -processors argument from the mksquashfs4 call, so it will use all available processors. This dramatically reduces the time to create squashfs filesystems. The times below are observed when building an image for my main router, the WatchGuard Firebox M300 (qoriq target): Before: real 4m45,973s After: real 0m23,497s With this commit `mksquashfs` may use more cores than defined via `-j`. This is the same behaviour as for archive creation of ImageBuilder, SDK or toolchain. There is no trivial way to limit `mksquashfs` CPU core usage to the amount of "free" make jobs since two running `mksquashfs` instances would each run with the total allowed number (-j) of threads. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> [extended reasoning in commit message] Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index e5b52d0e97..35a5e291c6 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -230,8 +230,7 @@ $(eval $(foreach S,$(NAND_BLOCKSIZE),$(call Image/mkfs/jffs2-nand/template,$(S))
define Image/mkfs/squashfs-common
$(STAGING_DIR_HOST)/bin/mksquashfs4 $(call mkfs_target_dir,$(1)) $@ \
-nopad -noappend -root-owned \
- -comp $(SQUASHFSCOMP) $(SQUASHFSOPT) \
- -processors 1
+ -comp $(SQUASHFSCOMP) $(SQUASHFSOPT)
endef
ifeq ($(CONFIG_TARGET_ROOTFS_SECURITY_LABELS),y)