aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2022-04-01 17:35:42 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2022-05-12 17:23:18 +0200
commit20ca59ceb78114d6e7607ae55b512f8b38a77a9c (patch)
tree392a2fa95555785018a361e466506fedc752ff15 /include/image.mk
parentd1b824650f1ee694ec2dbdd2f4f9ec64e650cf86 (diff)
downloadupstream-20ca59ceb78114d6e7607ae55b512f8b38a77a9c.tar.gz
upstream-20ca59ceb78114d6e7607ae55b512f8b38a77a9c.tar.bz2
upstream-20ca59ceb78114d6e7607ae55b512f8b38a77a9c.zip
image: drop unused 'BuildKernel/MkFIT'
The 'MkFIT' recipe is no longer used across whole codebase. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk8
1 files changed, 0 insertions, 8 deletions
diff --git a/include/image.mk b/include/image.mk
index b23e192c5d..bdcf20d30c 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -137,14 +137,6 @@ define Image/BuildKernel/MkuImage
-n '$(call toupper,$(ARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(4) $(5)
endef
-define Image/BuildKernel/MkFIT
- $(TOPDIR)/scripts/mkits.sh \
- -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) $(if $(3),-d $(3)) -C $(4) -a $(5) -e $(6) \
- -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
- -A $(LINUX_KARCH) -v $(LINUX_VERSION)
- PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
-endef
-
ifdef CONFIG_TARGET_IMAGES_GZIP
define Image/Gzip
rm -f $(1).gz