aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-08-19 01:23:41 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-08-19 01:37:35 +0100
commitc5616a8ae1649ef55d362462a39aa133b65dc1e3 (patch)
tree6d951707c94ea007cebe2406aaa957c9d1dbd596 /include/image.mk
parente826b642945ee7b196044a07faddd71c1bd6c6ef (diff)
downloadupstream-c5616a8ae1649ef55d362462a39aa133b65dc1e3.tar.gz
upstream-c5616a8ae1649ef55d362462a39aa133b65dc1e3.tar.bz2
upstream-c5616a8ae1649ef55d362462a39aa133b65dc1e3.zip
image: fix build with SELinux
The option '-xattr' for mksquashfs4 should be '-xattrs' which lead to build failure with SELinux enabled. Add the missing 's'. Fixes: 4baf47b9a8 ("images: squashfs: xattrs should not depend on buld host") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index d2b34d25a7..6298e3085e 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -75,7 +75,7 @@ JFFS2OPTS += $(MKFS_DEVTABLE_OPT)
SQUASHFS_BLOCKSIZE := $(CONFIG_TARGET_SQUASHFS_BLOCK_SIZE)k
SQUASHFSOPT := -b $(SQUASHFS_BLOCKSIZE)
SQUASHFSOPT += -p '/dev d 755 0 0' -p '/dev/console c 600 0 0 5 1'
-SQUASHFSOPT += $(if $(CONFIG_SELINUX),-xattr,-no-xattrs)
+SQUASHFSOPT += $(if $(CONFIG_SELINUX),-xattrs,-no-xattrs)
SQUASHFSCOMP := gzip
LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
ifeq ($(CONFIG_SQUASHFS_XZ),y)