aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-08-02 20:14:53 +0200
committerDaniel Golle <daniel@makrotopia.org>2021-08-03 18:28:53 +0100
commit4baf47b9a828b2e2ba2f174083676fe79b0ab527 (patch)
tree2457b3f53ff65c1a373b047cfb779e29f284703a /include/image.mk
parentaf76e26b557270307e05be168c3b9463886306f1 (diff)
downloadupstream-4baf47b9a828b2e2ba2f174083676fe79b0ab527.tar.gz
upstream-4baf47b9a828b2e2ba2f174083676fe79b0ab527.tar.bz2
upstream-4baf47b9a828b2e2ba2f174083676fe79b0ab527.zip
images: squashfs: xattrs should not depend on buld host
Enable xattr for the generated squashfs only if needed for SELinux. This eliminates warnings during boot on target when building (non-SELinux) OpenWrt on SELinux-enabled hosts like Fedora. Reported-by: fda77 <fda77@users.noreply.github.com> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index a7473abe68..d2b34d25a7 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -75,6 +75,7 @@ JFFS2OPTS += $(MKFS_DEVTABLE_OPT)
SQUASHFS_BLOCKSIZE := $(CONFIG_TARGET_SQUASHFS_BLOCK_SIZE)k
SQUASHFSOPT := -b $(SQUASHFS_BLOCKSIZE)
SQUASHFSOPT += -p '/dev d 755 0 0' -p '/dev/console c 600 0 0 5 1'
+SQUASHFSOPT += $(if $(CONFIG_SELINUX),-xattr,-no-xattrs)
SQUASHFSCOMP := gzip
LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
ifeq ($(CONFIG_SQUASHFS_XZ),y)