aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-17 17:31:09 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-19 14:32:12 +0100
commite6bcf1e4acc4901c1803cdccc4b9fabfd6d84c90 (patch)
treef7b66277175ff0ae6baf093db66ca929dfb2b225 /include/image.mk
parente3d5b384aa67c5562d59e8745fc6c48a9f2a997d (diff)
downloadupstream-e6bcf1e4acc4901c1803cdccc4b9fabfd6d84c90.tar.gz
upstream-e6bcf1e4acc4901c1803cdccc4b9fabfd6d84c90.tar.bz2
upstream-e6bcf1e4acc4901c1803cdccc4b9fabfd6d84c90.zip
build: add ABI_VERSION to binary package names
Add the ABI_VERSION source makefile variable to the binary package basename and resolve source dependencies on packages with ABI_VERSION set to such expanded names. If for example a package specifies DEPENDS:=libopenssl while the OpenSSL Makefile specifies ABI_VERSION:=1.0.0, the resulting ipk control data dependency will be "Depends: libopenssl1.0.0" and the libopenssl ipk file will be called "libopenssl1.0.0_<version>_<arch>.ipk". The next time a library such as OpenSSL is updated to an incompatible version, the ABI_VERSION shall be changed accordingly to prevent opkg from simply upgrading to an incompatible library without considering the dependencies of already installed packages. Also introduce another "SourceName" control field which is required by the newly introduced "scritps/ipkg-remove" to determine the proper related .ipk files to delete upon buildroot package clean operations. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index a2b106d909..8c4ca222df 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -279,8 +279,8 @@ ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
endif
mkfs_packages = $(filter-out @%,$(PACKAGES_$(call param_get,pkg,pkg=$(target_params))))
-mkfs_packages_add = $(filter-out -%,$(mkfs_packages))
-mkfs_packages_remove = $(patsubst -%,%,$(filter -%,$(mkfs_packages)))
+mkfs_packages_add = $(foreach pkg,$(filter-out -%,$(mkfs_packages)),$(pkg)$(call GetABISuffix,$(pkg)))
+mkfs_packages_remove = $(foreach pkg,$(patsubst -%,%,$(filter -%,$(mkfs_packages))),$(pkg)$(call GetABISuffix,$(pkg)))
mkfs_cur_target_dir = $(call mkfs_target_dir,pkg=$(target_params))
opkg_target = \