aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-06-30 01:02:43 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-07-13 21:24:30 +0100
commite3618eb2cc210763fe1b309fd7e337fdf8a98f0b (patch)
tree694199e59cbc42c63a92421d8947840222497534 /include/image.mk
parent3dbd74d03295f9fc357a88fa2160c75119908bfd (diff)
downloadupstream-e3618eb2cc210763fe1b309fd7e337fdf8a98f0b.tar.gz
upstream-e3618eb2cc210763fe1b309fd7e337fdf8a98f0b.tar.bz2
upstream-e3618eb2cc210763fe1b309fd7e337fdf8a98f0b.zip
build: store default/device packages in JSON
With this commit the `profiles.json` contain both the target specific `default_packages` as well as the device specific `device_packages` as a array of strings. This information is required for downstream projects like the various web-based interactive firmware generators. Signed-off-by: Daniel Golle <daniel@makrotopia.org> Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 263f7e5bbd119ebed1f514c16f659a2e2a2b132c)
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 15f4fe9d3b..a13f37f886 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -536,6 +536,7 @@ define Device/Build/image
IMAGE_TYPE=$(word 1,$(subst ., ,$(2))) \
IMAGE_PREFIX="$(IMAGE_PREFIX)" \
DEVICE_TITLE="$(DEVICE_TITLE)" \
+ DEVICE_PACKAGES="$(DEVICE_PACKAGES)" \
TARGET="$(BOARD)" \
SUBTARGET="$(if $(SUBTARGET),$(SUBTARGET),generic)" \
VERSION_NUMBER="$(VERSION_NUMBER)" \