aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-03-13 10:49:58 +0100
committerFelix Fietkau <nbd@nbd.name>2017-03-13 13:33:50 +0100
commit0d6494daf5cc7192f80c8a6af0aa5e1665ac07f2 (patch)
treee11c8513f4aa907df2f3cde08a8ff5f5968f684e /include/image.mk
parent080c6fa476d1320f83ad56e6aeaa292960f63dc1 (diff)
downloadupstream-0d6494daf5cc7192f80c8a6af0aa5e1665ac07f2.tar.gz
upstream-0d6494daf5cc7192f80c8a6af0aa5e1665ac07f2.tar.bz2
upstream-0d6494daf5cc7192f80c8a6af0aa5e1665ac07f2.zip
image.mk: force kernel rebuild on every run
DTS dependencies are not processed correctly so makes it safer against poentially stale builds Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 9bc30c663d..2153715a64 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -419,7 +419,7 @@ define Device/Build/initramfs
$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE)
cp $$^ $$@
- $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/$$(KERNEL_INITRAMFS_NAME) $(CURDIR)/Makefile $$(KERNEL_DEPENDS)
+ $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/$$(KERNEL_INITRAMFS_NAME) $(CURDIR)/Makefile $$(KERNEL_DEPENDS) image_prepare
@rm -f $$@
$$(call concat_cmd,$$(KERNEL_INITRAMFS))
endef
@@ -443,7 +443,7 @@ define Device/Build/kernel
ifdef CONFIG_IB
install: $$(KDIR_KERNEL_IMAGE)
endif
- $$(KDIR_KERNEL_IMAGE): $(KDIR)/$$(KERNEL_NAME) $(CURDIR)/Makefile $$(KERNEL_DEPENDS)
+ $$(KDIR_KERNEL_IMAGE): $(KDIR)/$$(KERNEL_NAME) $(CURDIR)/Makefile $$(KERNEL_DEPENDS) image_prepare
@rm -f $$@
$$(call concat_cmd,$$(KERNEL))
$$(if $$(KERNEL_SIZE),$$(call Build/check-size,$$(KERNEL_SIZE)))