aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-22 00:59:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-22 00:59:47 +0000
commitd9fc41ff70fc4cf8294f3ab488d058c1ed967d78 (patch)
tree43f374559f83a730db8e646b5f3ac03953610e70 /include/image.mk
parent6d33b871529a961144c3f43b05795248f364af00 (diff)
downloadupstream-d9fc41ff70fc4cf8294f3ab488d058c1ed967d78.tar.gz
upstream-d9fc41ff70fc4cf8294f3ab488d058c1ed967d78.tar.bz2
upstream-d9fc41ff70fc4cf8294f3ab488d058c1ed967d78.zip
add 0xdeadc0de to the jffs2 filesystem images
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4048 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index f30f0997ee..bf80e27990 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -17,6 +17,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
$(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
+
+ # add End-of-Filesystem markers
+ echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-64k
+ echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-128k
$(call Image/Build,jffs2-64k)
$(call Image/Build,jffs2-128k)