aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-02 16:09:15 +0000
commit7a5a2cec7a9bd2fef9aa3b7e1e78cf6714855d57 (patch)
tree57e890075610ad4408a6fa4b478be0f1eb678e2a /include/image.mk
parentac73de1e9395e3f8858693f368eff16fdd53f307 (diff)
downloadupstream-7a5a2cec7a9bd2fef9aa3b7e1e78cf6714855d57.tar.gz
upstream-7a5a2cec7a9bd2fef9aa3b7e1e78cf6714855d57.tar.bz2
upstream-7a5a2cec7a9bd2fef9aa3b7e1e78cf6714855d57.zip
Use find -exec instead of xargs
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6837 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 78e1a2fdc8..eb59ea651c 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -79,9 +79,9 @@ endif
define Image/mkfs/prepare/default
- find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
- find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
- find $(BUILD_DIR)/root -type d | xargs chmod 0755
+ find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
+ find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
+ find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
mkdir -p $(BUILD_DIR)/root/tmp
chmod 0777 $(BUILD_DIR)/root/tmp
endef