aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-03-06 21:06:30 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-03-07 09:59:07 +0100
commitcf1c7c0f17a45bba3e7ce1a3cd3f8f7efa7196c4 (patch)
tree1ebdd028994df38f302205f22dd849bfab2eb981 /include/image.mk
parent6ab50bb10ded770f023e14d63cac2522076f9daf (diff)
downloadupstream-cf1c7c0f17a45bba3e7ce1a3cd3f8f7efa7196c4.tar.gz
upstream-cf1c7c0f17a45bba3e7ce1a3cd3f8f7efa7196c4.tar.bz2
upstream-cf1c7c0f17a45bba3e7ce1a3cd3f8f7efa7196c4.zip
include/rootfs.mk: pass additional files dir to prepare_rootfs as an argument
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 723e4f1897..1cd8b75817 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -305,7 +305,7 @@ target-dir-%: FORCE
$(call opkg_package_files,$(mkfs_packages_add)))
-$(CP) -T $(mkfs_cur_target_dir).opkg/ $(mkfs_cur_target_dir)/etc/opkg/
rm -rf $(mkfs_cur_target_dir).opkg $(mkfs_cur_target_dir).conf
- $(call prepare_rootfs,$(mkfs_cur_target_dir))
+ $(call prepare_rootfs,$(mkfs_cur_target_dir),$(TOPDIR)/files)
$(KDIR)/root.%: kernel_prepare
$(call Image/mkfs/$(word 1,$(target_params)),$(target_params))