aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-03 16:08:12 +0100
committerFelix Fietkau <nbd@nbd.name>2017-11-03 16:21:24 +0100
commitc6f71ad30b768266a8fcc42af719881e93739365 (patch)
tree438d207b32e6c929a13447ade759b8c2c76ed968 /include/image.mk
parentfae5f02912cf358eee9e99e4f54f047f1788ca16 (diff)
downloadupstream-c6f71ad30b768266a8fcc42af719881e93739365.tar.gz
upstream-c6f71ad30b768266a8fcc42af719881e93739365.tar.bz2
upstream-c6f71ad30b768266a8fcc42af719881e93739365.zip
build: fix another regression in append-dtb fix
Filter out duplicate generated code for the same dts files Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 2d7b1ef998..96a8892115 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -437,10 +437,14 @@ endef
ifndef IB
define Device/Build/dtb
+ ifndef BUILD_DTS_$(1)
+ BUILD_DTS_$(1) := 1
$(KDIR)/image-$(1).dtb: FORCE
$(call Image/BuildDTB,$(strip $(2))/$(1).dts,$$@)
image_prepare: $(KDIR)/image-$(1).dtb
+ endif
+
endef
endif