aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-09 14:26:24 +0100
committerFelix Fietkau <nbd@nbd.name>2017-11-09 14:40:32 +0100
commitb0e6284879773e9ae407aeb7f37b9ab89e8056ab (patch)
tree525ccdb23f5046e313c76f97a93a80d276b6523d /include/image.mk
parent981be0c3bd96ccf0636bb473f21403319e4b2742 (diff)
downloadupstream-b0e6284879773e9ae407aeb7f37b9ab89e8056ab.tar.gz
upstream-b0e6284879773e9ae407aeb7f37b9ab89e8056ab.tar.bz2
upstream-b0e6284879773e9ae407aeb7f37b9ab89e8056ab.zip
build: fix generating dtb with / in DEVICE_DTS
Fixes layerscape build error Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 96a8892115..f4d0a157cd 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -440,7 +440,7 @@ define Device/Build/dtb
ifndef BUILD_DTS_$(1)
BUILD_DTS_$(1) := 1
$(KDIR)/image-$(1).dtb: FORCE
- $(call Image/BuildDTB,$(strip $(2))/$(1).dts,$$@)
+ $(call Image/BuildDTB,$(strip $(2))/$(strip $(3)).dts,$$@)
image_prepare: $(KDIR)/image-$(1).dtb
endif
@@ -450,8 +450,9 @@ endif
define Device/Build/kernel
$$(eval $$(foreach dts,$$(DEVICE_DTS), \
- $$(call Device/Build/dtb,$$(dts), \
- $$(if $$(DEVICE_DTS_DIR),$$(DEVICE_DTS_DIR),$$(DTS_DIR)) \
+ $$(call Device/Build/dtb,$$(notdir $$(dts)), \
+ $$(if $$(DEVICE_DTS_DIR),$$(DEVICE_DTS_DIR),$$(DTS_DIR)), \
+ $$(dts) \
) \
))