aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorMichal Sojka <sojkam1@fel.cvut.cz>2017-05-02 16:57:18 +0200
committerJo-Philipp Wich <jo@mein.io>2017-05-14 21:43:17 +0200
commitaa8e91a1e4d96a5a2bfe4437b61086c6c505edc1 (patch)
treea7bf5c9711b8aeb604ad25a6859193bc82115989 /include/image.mk
parent4a033475453b63d0d5ae41489e7c395882567698 (diff)
downloadupstream-aa8e91a1e4d96a5a2bfe4437b61086c6c505edc1.tar.gz
upstream-aa8e91a1e4d96a5a2bfe4437b61086c6c505edc1.tar.bz2
upstream-aa8e91a1e4d96a5a2bfe4437b61086c6c505edc1.zip
image.mk: Generate cpiogz with root-owned files
Some files (e.g. /etc/dropbear) need to be owned by root. Add cpio option to ensure that. Other image types (at least targz and squashfs) already have this. Signed-off-by: Michal Sojka <sojkam1@fel.cvut.cz>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index ad9535d018..3f5b4544e9 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -277,7 +277,7 @@ endif
ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
define Image/Build/cpiogz
- ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9n >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
+ ( cd $(TARGET_DIR); find . | cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
endef
endif