aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-03-28 14:59:51 +0000
committerPetr Štetiar <ynezz@true.cz>2019-06-25 14:12:22 +0000
commit62105e5c9a4ed8f205c48ef39f4aeedc34eef643 (patch)
tree520c22157cc3725e187f2c0e1550618f99d8aa41 /include/image.mk
parent83d9fb0a99e1a177a442a7ed8cd996309dda2083 (diff)
downloadupstream-62105e5c9a4ed8f205c48ef39f4aeedc34eef643.tar.gz
upstream-62105e5c9a4ed8f205c48ef39f4aeedc34eef643.tar.bz2
upstream-62105e5c9a4ed8f205c48ef39f4aeedc34eef643.zip
build: image: add IMG_ROOTFS and IMG_COMBINED variables
Adding those two variables in order to share them across the tree. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index f5da4853df..3702469823 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -42,6 +42,8 @@ IMG_PREFIX_VERNUM:=$(if $(CONFIG_VERSION_FILENAMES),$(call sanitize,$(VERSION_NU
IMG_PREFIX_VERCODE:=$(if $(CONFIG_VERSION_CODE_FILENAMES),$(call sanitize,$(VERSION_CODE))-)
IMG_PREFIX:=$(VERSION_DIST_SANITIZED)-$(IMG_PREFIX_VERNUM)$(IMG_PREFIX_VERCODE)$(IMG_PREFIX_EXTRA)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
+IMG_ROOTFS:=$(IMG_PREFIX)-rootfs
+IMG_COMBINED:=$(IMG_PREFIX)-combined
MKFS_DEVTABLE_OPT := -D $(INCLUDE_DIR)/device_table.txt
@@ -325,7 +327,7 @@ endif
ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
define Image/Build/cpiogz
- ( cd $(TARGET_DIR); find . | cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
+ ( cd $(TARGET_DIR); find . | cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
endef
endif