aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-04-01 13:53:31 +0200
committerPetr Štetiar <ynezz@true.cz>2019-04-01 13:53:31 +0200
commit6027e490930a2a5ade1c7056303ebc18740ec6f1 (patch)
treebc356b07c1009fca950637ce30acee71a42f0676 /include/image.mk
parent0a67e84baea3df19de2df6dd0e191183a96daf46 (diff)
downloadupstream-6027e490930a2a5ade1c7056303ebc18740ec6f1.tar.gz
upstream-6027e490930a2a5ade1c7056303ebc18740ec6f1.tar.bz2
upstream-6027e490930a2a5ade1c7056303ebc18740ec6f1.zip
build: image: Fix off-by-one in DTC kernel version checks
It was reported to me on IRC today, that my change causes issues with kernel versions between 4.14 and 4.19. It's because I've wrongly used `git describe` in order to get kernel version where we should disable noisy DTC checks, but I should've used `git tag --contains` instead. Fixes: cbbef976e2b ("build: dtc: Disable noisy warnings by default") Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/include/image.mk b/include/image.mk
index 9e40a54f51..edbd5b8daa 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -154,10 +154,10 @@ endif
# Disable noisy checks by default as in upstream
-ifeq ($(strip $(call kernel_patchver_ge,4.6.0)),1)
+ifeq ($(strip $(call kernel_patchver_ge,4.7.0)),1)
DTC_FLAGS += -Wno-unit_address_vs_reg
endif
-ifeq ($(strip $(call kernel_patchver_ge,4.11.0)),1)
+ifeq ($(strip $(call kernel_patchver_ge,4.12.0)),1)
DTC_FLAGS += \
-Wno-unit_address_vs_reg \
-Wno-simple_bus_reg \
@@ -166,12 +166,12 @@ ifeq ($(strip $(call kernel_patchver_ge,4.11.0)),1)
-Wno-pci_device_bus_num \
-Wno-pci_device_reg
endif
-ifeq ($(strip $(call kernel_patchver_ge,4.16.0)),1)
+ifeq ($(strip $(call kernel_patchver_ge,4.17.0)),1)
DTC_FLAGS += \
-Wno-avoid_unnecessary_addr_size \
-Wno-alias_paths
endif
-ifeq ($(strip $(call kernel_patchver_ge,4.17.0)),1)
+ifeq ($(strip $(call kernel_patchver_ge,4.18.0)),1)
DTC_FLAGS += \
-Wno-graph_child_address \
-Wno-graph_port \