aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-10-15 23:03:46 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-10-15 23:03:46 +0000
commit5ef8d0eae75ab9c2372048d7bd8866fa89af5263 (patch)
tree2b01b5039686d74b2b70b787e66dcb1aca38d895 /include/image.mk
parent140f6cc62c66913adb930023d349a1a87854774a (diff)
downloadupstream-5ef8d0eae75ab9c2372048d7bd8866fa89af5263.tar.gz
upstream-5ef8d0eae75ab9c2372048d7bd8866fa89af5263.tar.bz2
upstream-5ef8d0eae75ab9c2372048d7bd8866fa89af5263.zip
Prevent SSH keys from being chmoded to 644 (#664), looks like those are the only files concerned for now
SVN-Revision: 5135
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 0651679180..c738146851 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -57,7 +57,7 @@ endif
define Image/mkfs/prepare/default
- find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
+ find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
find $(BUILD_DIR)/root -type d | xargs chmod 0755
mkdir -p $(BUILD_DIR)/root/tmp