aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-03-15 21:51:19 +0100
committerMathias Kresin <dev@kresin.me>2018-03-15 22:27:37 +0100
commit5862f01ef71e7ec75394e877e74e781b7d08a4d3 (patch)
treee8adc9186569448548979afa6ef579f016850dc7 /include/image.mk
parent35e01cf68ad319ce1dda1673e63e4ef84f625f5b (diff)
downloadupstream-5862f01ef71e7ec75394e877e74e781b7d08a4d3.tar.gz
upstream-5862f01ef71e7ec75394e877e74e781b7d08a4d3.tar.bz2
upstream-5862f01ef71e7ec75394e877e74e781b7d08a4d3.zip
build: revert "make image target wait for initramfs"
This reverts commit 43be5087a915727e7dcb3459e2221f094c70811b. The change is incompatible with the image builder code. Luckily the RT-AC58U is no longer depending on the initramfs being available for the target's image generation rules. Reported-by: Venitex Aveon <aveon@aenote.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 64c224e55f..771f5b2c76 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -480,7 +480,7 @@ define Device/Build/image
ifndef IB
$$(ROOTFS/$(1)/$(3)): $(if $(TARGET_PER_DEVICE_ROOTFS),target-dir-$$(ROOTFS_ID/$(3)))
endif
- $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)): $$(KDIR_KERNEL_IMAGE) $$(ROOTFS/$(1)/$(3)) $$(if $$(CONFIG_TARGET_ROOTFS_INITRAMFS),$(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE))
+ $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)): $$(KDIR_KERNEL_IMAGE) $$(ROOTFS/$(1)/$(3))
@rm -f $$@
[ -f $$(word 1,$$^) -a -f $$(word 2,$$^) ]
$$(call concat_cmd,$(if $(IMAGE/$(2)/$(1)),$(IMAGE/$(2)/$(1)),$(IMAGE/$(2))))