aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2017-05-01 17:40:16 +0200
committerMathias Kresin <dev@kresin.me>2018-03-14 19:04:51 +0100
commit43be5087a915727e7dcb3459e2221f094c70811b (patch)
treeb67342709537fbdde369899aa858748454aec240 /include/image.mk
parente713b5ba6f28617e1db06fdaec6464d1ad7be4b4 (diff)
downloadupstream-43be5087a915727e7dcb3459e2221f094c70811b.tar.gz
upstream-43be5087a915727e7dcb3459e2221f094c70811b.tar.bz2
upstream-43be5087a915727e7dcb3459e2221f094c70811b.zip
build: make image target wait for initramfs
The image production rules does not have the initramfs-image as a dependency. So, from make’s perspective initramfs creation can run independently/in parallel with the image generation code in the target's Makefile. This is a problem for devices that have to use the initramfs for the image creation and can lead to broken images. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 771f5b2c76..64c224e55f 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -480,7 +480,7 @@ define Device/Build/image
ifndef IB
$$(ROOTFS/$(1)/$(3)): $(if $(TARGET_PER_DEVICE_ROOTFS),target-dir-$$(ROOTFS_ID/$(3)))
endif
- $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)): $$(KDIR_KERNEL_IMAGE) $$(ROOTFS/$(1)/$(3))
+ $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)): $$(KDIR_KERNEL_IMAGE) $$(ROOTFS/$(1)/$(3)) $$(if $$(CONFIG_TARGET_ROOTFS_INITRAMFS),$(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE))
@rm -f $$@
[ -f $$(word 1,$$^) -a -f $$(word 2,$$^) ]
$$(call concat_cmd,$(if $(IMAGE/$(2)/$(1)),$(IMAGE/$(2)/$(1)),$(IMAGE/$(2))))