aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-12 21:44:46 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-12 21:44:46 +0000
commit3684777fc7caaf330420b52b980b6dad661362d1 (patch)
treeb3f4adf3c4801a2f21c6402851fef99da379cb10 /include/image.mk
parent749ec9639b6a06281ab379bc3c8bfb6bd0369ce7 (diff)
downloadupstream-3684777fc7caaf330420b52b980b6dad661362d1.tar.gz
upstream-3684777fc7caaf330420b52b980b6dad661362d1.tar.bz2
upstream-3684777fc7caaf330420b52b980b6dad661362d1.zip
image: if possible use profile name when building .tar.gz images
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38374 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index e0731f0895..f5f1c8fb54 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -141,7 +141,7 @@ endif
ifneq ($(CONFIG_TARGET_ROOTFS_TARGZ),)
define Image/mkfs/targz
# Preserve permissions (-p) when building as non-root user
- $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
+ $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE),-$(PROFILE))-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
endef
endif