aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-02-22 22:35:08 +0000
committerTim Yardley <lst@openwrt.org>2007-02-22 22:35:08 +0000
commitfcbe667a8112d994e878d5c01e169c076ce01b91 (patch)
tree88a4b81701a303eac2e2c4e4c64c1d555aa68a23 /include/image.mk
parentef6f0dcf0e612325d00d1ce62e36ff23e7051817 (diff)
downloadupstream-fcbe667a8112d994e878d5c01e169c076ce01b91.tar.gz
upstream-fcbe667a8112d994e878d5c01e169c076ce01b91.tar.bz2
upstream-fcbe667a8112d994e878d5c01e169c076ce01b91.zip
make maxinodes configureable for ext2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6345 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 4f638f0260..ec0512f904 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -56,7 +56,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
define Image/mkfs/ext2
- $(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+ $(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
$(call Image/Build,ext2)
endef
endif