aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-02 17:24:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-02 17:24:20 +0000
commitd60f2546168f82bff620d2909936e27865d91273 (patch)
tree401e681e44ccf666f77fde83c6a4ecfc33b6767e /include/image.mk
parent8f9dcd2502d121c0a1668fcedbbba70c56c36f7b (diff)
downloadupstream-d60f2546168f82bff620d2909936e27865d91273.tar.gz
upstream-d60f2546168f82bff620d2909936e27865d91273.tar.bz2
upstream-d60f2546168f82bff620d2909936e27865d91273.zip
kernel build cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6464 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 9c170af11b..78e1a2fdc8 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -61,8 +61,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
endef
endif
-
-
+else
+ define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+ endef
endif