aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-08 04:06:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-08 04:06:29 +0000
commitfb0dfcb2beb2a1013ac55ef301e15699f88b9674 (patch)
treef12b96912d681ab89e99ade360277304780c96fd /include/image.mk
parent4059fb33b795edcf7b4425489b2e119b581e7198 (diff)
downloadupstream-fb0dfcb2beb2a1013ac55ef301e15699f88b9674.tar.gz
upstream-fb0dfcb2beb2a1013ac55ef301e15699f88b9674.tar.bz2
upstream-fb0dfcb2beb2a1013ac55ef301e15699f88b9674.zip
minor cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5718 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk16
1 files changed, 7 insertions, 9 deletions
diff --git a/include/image.mk b/include/image.mk
index 70677b9c2f..1c36327c61 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -75,10 +75,12 @@ define Image/mkfs/prepare
endef
define BuildImage
-compile:
+download:
+prepare:
+compile: compile-targets
$(call Build/Compile)
-install:
+install: compile install-targets
$(call Image/Prepare)
$(call Image/mkfs/prepare)
$(call Image/BuildKernel)
@@ -87,16 +89,12 @@ install:
$(call Image/mkfs/tgz)
$(call Image/mkfs/ext2)
-clean:
+clean: clean-targets
$(call Build/Clean)
-endef
compile-targets:
install-targets:
clean-targets:
+endef
+
-download:
-prepare:
-compile: compile-targets
-install: compile install-targets
-clean: clean-targets