aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-21 17:16:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-21 17:16:50 +0000
commit6e84b166c4911c234aba20c8da35f8e961c63bd7 (patch)
treee138e970fbc908b545200b9015dd51bdfe592169 /include/image.mk
parenta229f681cec8ad6a5623cb3fd829e35a83f8bbcc (diff)
downloadupstream-6e84b166c4911c234aba20c8da35f8e961c63bd7.tar.gz
upstream-6e84b166c4911c234aba20c8da35f8e961c63bd7.tar.bz2
upstream-6e84b166c4911c234aba20c8da35f8e961c63bd7.zip
change from /jffs to /overlay, patch from Daniel Dickinson
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20356 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 47871f9541..0ce6336cc5 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -62,14 +62,13 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(call Image/Build,jffs2-$(1))
endef
define Image/mkfs/jffs2
- rm -rf $(TARGET_DIR)/jffs
$(foreach SZ,$(JFFS2_BLOCKSIZE),$(call Image/mkfs/jffs2/sub,$(SZ)))
endef
endif
ifeq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),y)
define Image/mkfs/squashfs
- @mkdir -p $(TARGET_DIR)/jffs
+ @mkdir -p $(TARGET_DIR)/overlay
$(MKSQUASHFS_CMD) $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
$(call Image/Build,squashfs)
endef