aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-19 17:19:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-19 17:19:29 +0000
commit38afbcb1e2325f67c4c67bee044e6b04c8373574 (patch)
tree8989f852912e19f55e81e58d1ecdd652e11ed987 /include/image.mk
parent9798e24137237f83429d3827b8805c271917b82d (diff)
downloadupstream-38afbcb1e2325f67c4c67bee044e6b04c8373574.tar.gz
upstream-38afbcb1e2325f67c4c67bee044e6b04c8373574.tar.bz2
upstream-38afbcb1e2325f67c4c67bee044e6b04c8373574.zip
fix potential rootfs owner/group mismatch (tgz root only, patch from #4562)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14569 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 2b239ca3a3..7de2d6346e 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -62,7 +62,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
define Image/mkfs/tgz
- $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --owner=root --group=root -C $(TARGET_DIR)/ .
+ $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
endef
endif