aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-06-07 17:43:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-06-07 17:43:36 +0000
commit1d8beaa089db2c1dd64795406a20a6804c719ce0 (patch)
treec4993ef0e6120f78644bb2a9cc411038ee77e7a0 /include/image.mk
parent65e4e12512261fc8fb1d4a8b39654d973da3dfce (diff)
downloadupstream-1d8beaa089db2c1dd64795406a20a6804c719ce0.tar.gz
upstream-1d8beaa089db2c1dd64795406a20a6804c719ce0.tar.bz2
upstream-1d8beaa089db2c1dd64795406a20a6804c719ce0.zip
[images] strip kernel version from image names
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11398 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index d7385439c4..efbc76db36 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -61,18 +61,18 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
define Image/mkfs/tgz
- $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(TARGET_DIR)/ .
+ $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --owner=root --group=root -C $(TARGET_DIR)/ .
endef
endif
ifeq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),y)
define Image/mkfs/cpiogz
- ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.cpio.gz )
+ ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/openwrt-$(BOARD)-rootfs.cpio.gz )
endef
endif
else
define Image/BuildKernel
- cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
$(call Image/Build/Initramfs)
endef
endif