aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-12 19:18:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-12 19:18:38 +0000
commit1cabba028e019be3a33c936c2fbe4bdf6a19fb53 (patch)
tree76c846e43279bd22c30a82c78efcc81ca125e6a2 /include/image.mk
parent07bdd5fe16bc0ebca83a00a8628be925c2956540 (diff)
downloadupstream-1cabba028e019be3a33c936c2fbe4bdf6a19fb53.tar.gz
upstream-1cabba028e019be3a33c936c2fbe4bdf6a19fb53.tar.bz2
upstream-1cabba028e019be3a33c936c2fbe4bdf6a19fb53.zip
revert find | xargs => find | exec changes - this is completely unnecessary and introduces additional dependencies that we do not need
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6942 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index eb59ea651c..0e6a7cdbea 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -79,9 +79,9 @@ endif
define Image/mkfs/prepare/default
- find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
- find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
- find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
+ find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs -r chmod 0644
+ find $(BUILD_DIR)/root -type f -perm +0100 | xargs -r chmod 0755
+ find $(BUILD_DIR)/root -type d | xargs -r chmod 0755
mkdir -p $(BUILD_DIR)/root/tmp
chmod 0777 $(BUILD_DIR)/root/tmp
endef