aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-05 18:02:00 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-05 18:02:00 +0000
commit15c52a84fba09deed2cdcbbe54d448eb222c0c6a (patch)
tree4cf4bc5f8db1f76c8acb427be26060712f05fd28 /include/image.mk
parent8ac33e5cdf0f7fece847d7912adb46889b0bb713 (diff)
downloadupstream-15c52a84fba09deed2cdcbbe54d448eb222c0c6a.tar.gz
upstream-15c52a84fba09deed2cdcbbe54d448eb222c0c6a.tar.bz2
upstream-15c52a84fba09deed2cdcbbe54d448eb222c0c6a.zip
[package] base-files: add permission exceptions, do not clobber shadow permissions - based on patch by Mark Mentovai <mark@moxienet.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32073 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 473e391ae4..b0d6dfae61 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -142,7 +142,7 @@ endif
define Image/mkfs/prepare/default
# Use symbolic permissions to avoid clobbering SUID/SGID/sticky bits
- - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -print0 | $(XARGS) -0 chmod u+rw,g+r,o+r
+ - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -not -name 'shadow' -print0 | $(XARGS) -0 chmod u+rw,g+r,o+r
- $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
- $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
$(INSTALL_DIR) $(TARGET_DIR)/tmp