aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-10-08 18:53:19 +0000
committerJohn Crispin <blogic@openwrt.org>2007-10-08 18:53:19 +0000
commit0f0020cac022f0dcf0462f41125dad2a4e0675ff (patch)
tree269d33b9b63507ab401ff3260f8a840fc50c4316 /include/image.mk
parent91298e7d33bf3aa1e63376a982688a8e3e9b6151 (diff)
downloadupstream-0f0020cac022f0dcf0462f41125dad2a4e0675ff.tar.gz
upstream-0f0020cac022f0dcf0462f41125dad2a4e0675ff.tar.bz2
upstream-0f0020cac022f0dcf0462f41125dad2a4e0675ff.zip
added generation of x86 livecds, from #2391
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9191 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 68ce0480d1..fea7d1ce6f 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -81,6 +81,12 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
endef
endif
+ifeq ($(CONFIG_TARGET_ROOTFS_ISO),y)
+ define Image/mkfs/iso
+ $(call Image/Build,iso)
+ endef
+endif
+
define Image/mkfs/prepare/default
find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
@@ -113,6 +119,7 @@ ifneq ($(IB),1)
$(call Image/mkfs/squashfs)
$(call Image/mkfs/tgz)
$(call Image/mkfs/ext2)
+ $(call Image/mkfs/iso)
else
install: compile install-targets
$(call Image/BuildKernel)
@@ -120,6 +127,7 @@ else
$(call Image/mkfs/squashfs)
$(call Image/mkfs/tgz)
$(call Image/mkfs/ext2)
+ $(call Image/mkfs/iso)
endif
ifneq ($(IB),1)