aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-legacy.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-07-14 19:35:02 +0200
committerMathias Kresin <dev@kresin.me>2017-07-15 07:02:59 +0200
commit9fe9175c2f674607f8e26214b45382591c27f54a (patch)
treeeba8d4ba631cc77db39fd9b2eb46b9b7f4801636 /include/image-legacy.mk
parent4531bc4267c7701e3615a806a0fde8212076699a (diff)
downloadupstream-9fe9175c2f674607f8e26214b45382591c27f54a.tar.gz
upstream-9fe9175c2f674607f8e26214b45382591c27f54a.tar.bz2
upstream-9fe9175c2f674607f8e26214b45382591c27f54a.zip
image: fix ar71xx legacy images
If TARGET_PER_DEVICE_ROOTFS and DEVICE_PACKAGES are used for ar71xx legacy images: - an already jffs2 padded squashfs rootfs is overwritten with an unpadded/raw one. - the squashfs-raw and squashfs-64k rootfs are not replaced by the ones including the DEVICE_PACKAGES Call Image/Build/squashfs after the DEVICE_PACKAGES are added to the base squashfs rootfs to fix the issues. Fixes: FS#904 Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include/image-legacy.mk')
-rw-r--r--include/image-legacy.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-legacy.mk b/include/image-legacy.mk
index 1864d714e5..1ccaec09b0 100644
--- a/include/image-legacy.mk
+++ b/include/image-legacy.mk
@@ -48,6 +48,7 @@ endef
ifdef TARGET_PER_DEVICE_ROOTFS
define Image/Build/Profile/Filesystem
cp $(KDIR)/root.$(2)+pkg=$(3) $(KDIR)/root.$(2)
+ $(call Image/Build/$(2),$(2))
$(call Image/Build/Profile,$(1),$(2))
endef
else