aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorRani Hod <rani.hod@gmail.com>2023-04-09 22:47:58 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-29 22:05:20 +0200
commite4c7703d2a62b8914e4723adae3f67c68a57532c (patch)
tree242200c1e7cfc5a574aeb6fa08051e387078bd5c /include/image-commands.mk
parent829a50d242287060c749882b7bf9af4c6a4505b4 (diff)
downloadupstream-e4c7703d2a62b8914e4723adae3f67c68a57532c.tar.gz
upstream-e4c7703d2a62b8914e4723adae3f67c68a57532c.tar.bz2
upstream-e4c7703d2a62b8914e4723adae3f67c68a57532c.zip
ramips: add support for D-Link DAP-1620 B1
The DAP-1620 rev B is a wall-plug AC1300 repeater. Specifications: - MT7621AT, 256 MiB RAM, 16 MiB SPI NOR - MT7615DN 2x2 802.11n +2x2 802.11ac (DBDC) - Ethernet: 1 port 10/100/1000 - Status LEDs (1x red+green) - LED RSSI bargraph (2x green, 1x red+green) Installation: - Keep reset button pressed during plug-in - Web Recovery Updater is at 192.168.0.50 - Upload factory.bin, confirm flashing (seems to work best with Chromium-based browsers) Revert to OEM firmware: - tail -c+117 DAP1620B1_FW212B03.bin | \ openssl aes-256-cbc -d -md md5 -out decrypted.bin \ -k 905503a4e0c3cd3c1ce062246de427a68962347e - flash decrypted.bin via D-Link Web Recovery Signed-off-by: Rani Hod <rani.hod@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 47d9d1ab88..0c13f30fef 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -126,6 +126,13 @@ define Build/append-string
echo -n $(1) >> $@
endef
+define Build/append-md5sum-ascii-salted
+ cp $@ $@.salted
+ echo -ne $(1) >> $@.salted
+ $(STAGING_DIR_HOST)/bin/mkhash md5 $@.salted | head -c32 >> $@
+ rm $@.salted
+endef
+
define Build/append-ubi
sh $(TOPDIR)/scripts/ubinize-image.sh \
$(if $(UBOOTENV_IN_UBI),--uboot-env) \