aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorWenli Looi <wlooi@ucalgary.ca>2023-03-30 22:27:11 +0000
committerDaniel Golle <daniel@makrotopia.org>2023-07-13 12:05:28 +0100
commit977ee439d7068e405361322013e9a2114bfefcda (patch)
tree45f519f8cc792cbf56981131f70b46da4335bf8c /include/image-commands.mk
parentb7fac1bf8c6f975607427734f85318c69aacaeb6 (diff)
downloadupstream-977ee439d7068e405361322013e9a2114bfefcda.tar.gz
upstream-977ee439d7068e405361322013e9a2114bfefcda.tar.bz2
upstream-977ee439d7068e405361322013e9a2114bfefcda.zip
image: add additional fields to Netgear encrypted image
These fields are used for EAX12 and EX6250v2 series, and perhaps other devices. Compatibility is preserved with the WAX202 and WAX206. In addition, adds the related vars to DEVICE_VARS so that the variables work correctly with multiple devices. References in GPL source: https://www.downloads.netgear.com/files/GPL/EAX12_EAX11v2_EAX15v2_GPL_V1.0.3.34_src.tar.gz * tools/imgencoder/src/gj_enc.c Contains code that generates the encrypted image. Signed-off-by: Wenli Looi <wlooi@ucalgary.ca> (cherry picked from commit 0a1ebccc8702cadc50bc096f1e185472f3927786)
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 1d69485019..dc6ee6e7c1 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -423,6 +423,8 @@ define Build/netgear-encrypted-factory
--output-file $@ \
--model $(NETGEAR_ENC_MODEL) \
--region $(NETGEAR_ENC_REGION) \
+ $(if $(NETGEAR_ENC_HW_ID_LIST),--hw-id-list "$(NETGEAR_ENC_HW_ID_LIST)") \
+ $(if $(NETGEAR_ENC_MODEL_LIST),--model-list "$(NETGEAR_ENC_MODEL_LIST)") \
--version V1.0.0.0.$(shell cat $(VERSION_DIST)| sed -e 's/[[:space:]]/-/g').$(firstword $(subst -, ,$(REVISION))) \
--encryption-block-size 0x20000 \
--openssl-bin "$(STAGING_DIR_HOST)/bin/openssl" \