aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-06-04 15:57:25 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-06-09 19:23:03 +0100
commitd05d886d22ed1f395d7d4ee47b2e2075b58fa9b9 (patch)
tree165f8a55f97ac4f106950414e58a3e5aa90addc0 /include/image-commands.mk
parentd46e13d8648a3969789d6e0bd28eddfd05f121ee (diff)
downloadupstream-d05d886d22ed1f395d7d4ee47b2e2075b58fa9b9.tar.gz
upstream-d05d886d22ed1f395d7d4ee47b2e2075b58fa9b9.tar.bz2
upstream-d05d886d22ed1f395d7d4ee47b2e2075b58fa9b9.zip
image: improve uImage.FIT device tree overlay support
Instead of generating full config nodes incl. kernel, generate minimal config nodes for device tree overlays to be applied to the main config. In this way, multiple device tree overlays can be applied more easily. While at it change filenames to upstream style, ie. use dtso and dtbo suffix for device tree overlays. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 6b01d40bfedb42323a1324e1b5624f192a4c91de)
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index ea602662a5..1d69485019 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -307,7 +307,7 @@ define Build/fit
$(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
$(if $(DEVICE_DTS_DELIMITER),-l $(DEVICE_DTS_DELIMITER)) \
$(if $(DEVICE_DTS_LOADADDR),-s $(DEVICE_DTS_LOADADDR)) \
- $(if $(DEVICE_DTS_OVERLAY),$(foreach dtso,$(DEVICE_DTS_OVERLAY), -O $(dtso):$(KERNEL_BUILD_DIR)/image-$(dtso).dtb)) \
+ $(if $(DEVICE_DTS_OVERLAY),$(foreach dtso,$(DEVICE_DTS_OVERLAY), -O $(dtso):$(KERNEL_BUILD_DIR)/image-$(dtso).dtbo)) \
-c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
-A $(LINUX_KARCH) -v $(LINUX_VERSION)
PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage $(if $(findstring external,$(word 3,$(1))),\