aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorMarkus Stockhausen <markus.stockhausen@gmx.de>2022-07-26 13:44:48 +0200
committerSander Vanheule <sander@svanheule.net>2023-01-02 10:15:37 +0100
commita51ca085bff2f8c6155f18bb767fe2d053bbc90d (patch)
tree1ecf0faa57f26f0fff8e7b97c0afcbc35bba5ba3 /include/image-commands.mk
parentc9a7c00f809f6a0a49b600e0ea4f060dfcd0f11f (diff)
downloadupstream-a51ca085bff2f8c6155f18bb767fe2d053bbc90d.tar.gz
upstream-a51ca085bff2f8c6155f18bb767fe2d053bbc90d.tar.bz2
upstream-a51ca085bff2f8c6155f18bb767fe2d053bbc90d.zip
tools: Add gzip-libdeflate advanced compressor
Several devices provide U-Boot versions with only gzip compressed kernel support (e.g. Realtek switches). This compression method produces larger images than lzma. To save space on flash and avoid going the hard way with lzma-loader we can make use of enhanced gzip tool based on libdeflate compression library from https://github.com/ebiggers/libdeflate. It keeps 100% deflate/gzip compatibility while improving compression ratio. The image can be unpacked by the default inflate routines inside U-Boot. Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de> [Switched to v1.15 and made it work with cmake] Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> Reviewed-by: Robert Marko <robimarko@gmail.com> Reviewed-by: Rosen Penev <rosenp@gmail.com> Reviewed-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 074e40e4e8..15084093d2 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -306,6 +306,11 @@ define Build/fit
@mv $@.new $@
endef
+define Build/libdeflate-gzip
+ $(STAGING_DIR_HOST)/bin/libdeflate-gzip -f -12 -c $@ $(1) > $@.new
+ @mv $@.new $@
+endef
+
define Build/gzip
$(STAGING_DIR_HOST)/bin/gzip -f -9n -c $@ $(1) > $@.new
@mv $@.new $@