aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-11-07 00:42:40 +0100
committerDavid Bauer <mail@david-bauer.net>2022-11-08 12:16:36 +0100
commita208f0a9bec723e8bec3c45cc10931494d65156b (patch)
treefe394ff122f671d4c488242e2e76d77095489533 /include/image-commands.mk
parentb066ad7d9aa5221bfd334a3017abe9bcd171b33f (diff)
downloadupstream-a208f0a9bec723e8bec3c45cc10931494d65156b.tar.gz
upstream-a208f0a9bec723e8bec3c45cc10931494d65156b.tar.bz2
upstream-a208f0a9bec723e8bec3c45cc10931494d65156b.zip
mkits: support definition of DTB loadaddr
Support defining a per-device loadaddress for the DTB. This is required for devices which to not align the DTB from the bootloader correctly. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 492e6933f1..1f6ba1c15a 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -296,6 +296,7 @@ define Build/fit
-a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
$(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
$(if $(DEVICE_DTS_DELIMITER),-l $(DEVICE_DTS_DELIMITER)) \
+ $(if $(DEVICE_DTS_LOADADDR),-s $(DEVICE_DTS_LOADADDR)) \
$(if $(DEVICE_DTS_OVERLAY),$(foreach dtso,$(DEVICE_DTS_OVERLAY), -O $(dtso):$(KERNEL_BUILD_DIR)/image-$(dtso).dtb)) \
-c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
-A $(LINUX_KARCH) -v $(LINUX_VERSION)