aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-11-29 15:26:25 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-12-05 01:28:28 +0000
commit2f14c17501fda87c7d608af0ce56be88d98f337e (patch)
tree48590c172c0ee301ccd10edd9e1408e9e85fbb31 /include/image-commands.mk
parent644175c29ca11e0a008c58c82986045f738f5c6f (diff)
downloadupstream-2f14c17501fda87c7d608af0ce56be88d98f337e.tar.gz
upstream-2f14c17501fda87c7d608af0ce56be88d98f337e.tar.bz2
upstream-2f14c17501fda87c7d608af0ce56be88d98f337e.zip
build: make sure that $(STAGING_DIR_IMAGE) exists
Call 'mkdir -p $(STAGING_DIR_IMAGE)' before trying to store files in this potentially non-existing folder. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 1f6ba1c15a..41e1c96948 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -53,6 +53,7 @@ define Build/append-image-stage
cp "$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1)" "$@.stripmeta"
fwtool -s /dev/null -t "$@.stripmeta" || :
fwtool -i /dev/null -t "$@.stripmeta" || :
+ mkdir -p "$(STAGING_DIR_IMAGE)"
dd if="$@.stripmeta" of="$(STAGING_DIR_IMAGE)/$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))-$(DEVICE_NAME)-$(1)"
dd if="$@.stripmeta" >> "$@"
rm "$@.stripmeta"