aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-17 21:59:35 +0100
committerMathias Kresin <dev@kresin.me>2018-12-17 23:21:40 +0100
commit09004e6e13a85052cd56c58602d1300d6be52fc7 (patch)
treea52eed53c09486e47ec0ea11eba279e00253152e /include/image-commands.mk
parent38cae44e5107822e55ce762651c93a390e0d0b6e (diff)
downloadupstream-09004e6e13a85052cd56c58602d1300d6be52fc7.tar.gz
upstream-09004e6e13a85052cd56c58602d1300d6be52fc7.tar.bz2
upstream-09004e6e13a85052cd56c58602d1300d6be52fc7.zip
build: drop cameo-factory recipe
The cameo factory images are created using existing image build commands, which makes the code obsolete. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk12
1 files changed, 0 insertions, 12 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 49138a216d..5e24c5e3aa 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -44,18 +44,6 @@ define Build/buffalo-dhp-image
mv $@.new $@
endef
-# blow up binary to given size and put a given string at its end:
-# cameo-factory <size[k]> <string>
-define Build/cameo-factory
- factory_stamp=$(word 2,$(1)); \
- ((reduced_size=$(subst k,*1024,$(word 1,$(1)))-$${#factory_stamp})); \
- ( \
- dd if=$@ bs=$$reduced_size conv=sync; \
- echo -n $$factory_stamp; \
- ) > $@.new && \
- mv $@.new $@
-endef
-
define Build/eva-image
$(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
mv $@.new $@