aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorDamien Mascord <tusker@tusker.org>2021-07-19 14:21:44 +1000
committerChristian Lamparter <chunkeey@gmail.com>2021-09-23 20:49:32 +0200
commitfd67908647390b916470501c88b4f5258123da95 (patch)
tree98f1a3a76f3823541543acc913be1b804d03cf36 /include/image-commands.mk
parent96e05e2e36fc3d0a893702a7c445aac0348320a4 (diff)
downloadupstream-fd67908647390b916470501c88b4f5258123da95.tar.gz
upstream-fd67908647390b916470501c88b4f5258123da95.tar.bz2
upstream-fd67908647390b916470501c88b4f5258123da95.zip
scripts: mkits.sh: Allow legacy @ mode for dts creation
commit 5ec60cbe9d94 ("scripts: mkits.sh: replace @ with - in nodes") broke support for Meraki MR32 and this patch makes the replacement configurable allowing for specifying the @ or - or whatever character that is desired to retain backwards compatibility with existing devices. For example, this patch includes the fix for the Meraki MR32 in target/linux/bcm53xx/image for meraki_mr32: DEVICE_DTS_DELIMITER := @ DEVICE_DTS_CONFIG := config@1 Fixes: 5ec60cbe9d94 ("scripts: mkits.sh: replace @ with - in nodes") Signed-off-by: Damien Mascord <tusker@tusker.org> [Added tags, checkpatch.pl fixes, noted that this is for old stuff] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index fa36885038..1c9e8c12bb 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -232,6 +232,7 @@ define Build/fit
-i $(KERNEL_BUILD_DIR)/initrd.cpio$(strip $(call Build/initrd_compression)))) \
-a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
$(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
+ $(if $(DEVICE_DTS_DELIMITER),-l $(DEVICE_DTS_DELIMITER)) \
$(if $(DEVICE_DTS_OVERLAY),$(foreach dtso,$(DEVICE_DTS_OVERLAY), -O $(dtso):$(KERNEL_BUILD_DIR)/image-$(dtso).dtb)) \
-c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
-A $(LINUX_KARCH) -v $(LINUX_VERSION)