aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-02-01 21:35:06 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2022-02-01 21:35:15 +0200
commitcd6a6e3030ff9b758469cc159c219bc7a49df5e8 (patch)
tree2904885f0adf186677182ad246979d5e2a9f9e63 /include/image-commands.mk
parentda8b720b0ecbb6d58f28a31b082b0c53be149a5a (diff)
downloadupstream-cd6a6e3030ff9b758469cc159c219bc7a49df5e8.tar.gz
upstream-cd6a6e3030ff9b758469cc159c219bc7a49df5e8.tar.bz2
upstream-cd6a6e3030ff9b758469cc159c219bc7a49df5e8.zip
Revert "ramips: add support for ipTIME AX2004M"
Commit f4a79148f8cb ("ramips: add support for ipTIME AX2004M") seems to leak KERNEL_LOADADDR 0x82000000 to other devices, causing the to no longer boot. The leak is visible in u-boot: Using 'config-1' configuration Trying 'kernel-1' kernel subimage Description: MIPS OpenWrt Linux-5.10.92 Type: Kernel Image Compression: lzma compressed Data Start: 0x840000e4 Data Size: 10750165 Bytes = 10.3 MiB Architecture: MIPS OS: Linux Load Address: 0x82000000 Entry Point: 0x82000000 Normally, it should look like this: Using 'config-1' configuration Trying 'kernel-1' kernel subimage Description: MIPS OpenWrt Linux-5.10.92 Type: Kernel Image Compression: lzma compressed Data Start: 0xbfca00e4 Data Size: 2652547 Bytes = 2.5 MiB Architecture: MIPS OS: Linux Load Address: 0x80001000 Entry Point: 0x80001000 Revert the commit to avoid more people soft-bricking their devices. This reverts commit f4a79148f8cbb7dfbcddfb0c1128caec45a01596. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 0 insertions, 5 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 485d870f05..eda3fee94b 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -295,11 +295,6 @@ define Build/install-dtb
)
endef
-define Build/iptime-crc32
- $(STAGING_DIR_HOST)/bin/iptime-crc32 $(1) $@ $@.new
- mv $@.new $@
-endef
-
define Build/iptime-naspkg
$(STAGING_DIR_HOST)/bin/iptime-naspkg $(1) $@ $@.new
mv $@.new $@