aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2021-04-23 18:36:15 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-10-30 22:05:25 +0200
commit1b814974e12ede0ade19302332d49336ae208f08 (patch)
treefbe0d5254abecf4bbd03d6fc6c1a3f934af5dd38 /include/image-commands.mk
parent1b18195f59b09844ab8fdfd669bc506c25df111b (diff)
downloadupstream-1b814974e12ede0ade19302332d49336ae208f08.tar.gz
upstream-1b814974e12ede0ade19302332d49336ae208f08.tar.bz2
upstream-1b814974e12ede0ade19302332d49336ae208f08.zip
build: move elecom-wrc-gs-factory to image-commands.mk
ELECOM WRC-X3200GST3 uses the same header/footer as WRC-GS/GST devices in ramips/mt7621 subtarget, so move "Build/elecom-wrc-gs-factory" to image-commands.mk to use from mediatek/mt7622 subtarget. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 1c9e8c12bb..91865e1e7e 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -187,6 +187,19 @@ define Build/elecom-product-header
mv $(fw).new $(fw)
endef
+define Build/elecom-wrc-gs-factory
+ $(eval product=$(word 1,$(1)))
+ $(eval version=$(word 2,$(1)))
+ $(eval hash_opt=$(word 3,$(1)))
+ $(MKHASH) md5 $(hash_opt) $@ >> $@
+ ( \
+ echo -n "ELECOM $(product) v$(version)" | \
+ dd bs=32 count=1 conv=sync; \
+ dd if=$@; \
+ ) > $@.new
+ mv $@.new $@
+endef
+
define Build/elx-header
$(eval hw_id=$(word 1,$(1)))
$(eval xor_pattern=$(word 2,$(1)))