aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-01-08 19:28:09 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-01-15 19:29:42 +0100
commit144609bb3dbed2d612031b7db62740688929161e (patch)
tree2e85c6eaec99f6f631da0c8d7632d6f05c40d1ec /include/image-commands.mk
parent872b65ecc882c6b9afda9582932c62bc43b6745e (diff)
downloadupstream-144609bb3dbed2d612031b7db62740688929161e.tar.gz
upstream-144609bb3dbed2d612031b7db62740688929161e.tar.bz2
upstream-144609bb3dbed2d612031b7db62740688929161e.zip
build: move Build/copy-file to image-commands.mk
This is makro is present in more than one place. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 913e1c2411..158af853a5 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -196,6 +196,10 @@ define Build/check-size
}
endef
+define Build/copy-file
+ cat "$(1)" > "$@"
+endef
+
define Build/elecom-product-header
$(eval product=$(word 1,$(1)))
$(eval fw=$(if $(word 2,$(1)),$(word 2,$(1)),$@))