aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-24 22:53:23 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-24 22:55:16 +0000
commitb6c366efa89dcaa96072b0a12a451f873aa90077 (patch)
tree3299dc73f79ca438d2c261d00c1c31a550e9c515 /include/image-commands.mk
parenta3611432a6c3490fb2b6fdbc1ce664cf70900668 (diff)
downloadupstream-b6c366efa89dcaa96072b0a12a451f873aa90077.tar.gz
upstream-b6c366efa89dcaa96072b0a12a451f873aa90077.tar.bz2
upstream-b6c366efa89dcaa96072b0a12a451f873aa90077.zip
image: fix append-image when building multiple profiles
In case CONFIG_TARGET_MULTI_PROFILE is set, IMG_PREFIX cannot be expanded. Use DEVICE_IMG_PREFIX instead and make sure it's defined. Fixes: 8f89b1ab0f ("image: add 'append-image' build command") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index ec4f9624f5..2c56ed8d1d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -28,7 +28,7 @@ define Build/append-kernel
endef
define Build/append-image
- dd if=$(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE_SANITIZED),-$(PROFILE_SANITIZED))-$(1) >> $@
+ dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
endef
compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)