aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-03-28 14:21:18 +0000
committerPetr Štetiar <ynezz@true.cz>2019-06-25 14:12:22 +0000
commit97833a57eff148508b1dd1515c51fdb0f8619803 (patch)
tree0de377860ac83f7163a4a34fd0cafe588103aeeb /include/image-commands.mk
parent9c8e0b0e8af9827dc83989f3b18b4b18c47eb554 (diff)
downloadupstream-97833a57eff148508b1dd1515c51fdb0f8619803.tar.gz
upstream-97833a57eff148508b1dd1515c51fdb0f8619803.tar.bz2
upstream-97833a57eff148508b1dd1515c51fdb0f8619803.zip
build: image: add pad-to and pad-rootfs-squashfs helpers
For better reusability. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 8251a81400..06c084c48b 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -230,8 +230,7 @@ define Build/append-uboot
endef
define Build/pad-to
- dd if=$@ of=$@.new bs=$(1) conv=sync
- mv $@.new $@
+ $(call Image/pad-to,$@,$(1))
endef
define Build/pad-extra