aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-03-25 19:18:37 +0100
committerMathias Kresin <dev@kresin.me>2017-06-24 22:36:38 +0200
commit8e0d7d6574139e1ab4f99926e2cd09f6959d1073 (patch)
tree0c9db24d1d56955b66af556dc51b5f7054ce5b64 /include/image-commands.mk
parentd165f1f3bcb7330d008d68c2c9b4538c5fd3ebce (diff)
downloadupstream-8e0d7d6574139e1ab4f99926e2cd09f6959d1073.tar.gz
upstream-8e0d7d6574139e1ab4f99926e2cd09f6959d1073.tar.bz2
upstream-8e0d7d6574139e1ab4f99926e2cd09f6959d1073.zip
build: move lzma2eva build step to image-commands.mk
Move it to image-commands.mk so that it can used by other targets with eva based boards as well. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index c1d89825a3..093b93d0e9 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -44,6 +44,11 @@ define Build/buffalo-dhp-image
mv $@.new $@
endef
+define Build/eva-image
+ $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
+ mv $@.new $@
+endef
+
define Build/netgear-chk
$(STAGING_DIR_HOST)/bin/mkchkimg \
-o $@.new \