aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-10-02 22:43:58 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-10-07 22:14:35 +0200
commit5933958168c84d7ade94ce8bec451da2df064ead (patch)
tree7a6150d6d8eb151656a16a7b26d5bdac5374d6fe /include/image-commands.mk
parent0fa1dd71ccf5456e1a55dd492e9a42d9b71185ba (diff)
downloadupstream-5933958168c84d7ade94ce8bec451da2df064ead.tar.gz
upstream-5933958168c84d7ade94ce8bec451da2df064ead.tar.bz2
upstream-5933958168c84d7ade94ce8bec451da2df064ead.zip
image: ignore usign build errors
The tl-wa850re-v2 images from the ar71xx/tiny target are getting too big with the default packages. The size check is done before the meta data is added so there is no file to add meta data to or to sign. Originally errors in Build/append-metadata were getting ignored, but if the signing fails the error is not ignored. This adds a check if the file to be signed is there and only does the signing if it is there. This way it does not fail if the package creation was already aborted earlier. Fixes: 848b455d2e94 ("image: use ucert to append signature") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index ae01706b14..05d36093d3 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -332,7 +332,7 @@ metadata_json = \
define Build/append-metadata
$(if $(SUPPORTED_DEVICES),-echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
- [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" ] || { \
+ [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" -o ! -s "$@" ] || { \
cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
ucert -A -c "$@.ucert" -x "$@.sig" ;\