aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorSven Eckelmann <sven@narfation.org>2018-03-05 09:51:47 +0100
committerMathias Kresin <dev@kresin.me>2018-03-17 08:09:04 +0100
commit1b773a46c2023ef32ddbbc3835e20b6c216b184e (patch)
tree3b9ec159386fa5d6a6df38fb9aad9df453a428a3 /include/image-commands.mk
parentdbdc26ba33c19274e54b92e273073117b9e89ccb (diff)
downloadupstream-1b773a46c2023ef32ddbbc3835e20b6c216b184e.tar.gz
upstream-1b773a46c2023ef32ddbbc3835e20b6c216b184e.tar.bz2
upstream-1b773a46c2023ef32ddbbc3835e20b6c216b184e.zip
build: Allow to change the FIT config section name
Some devices only boot when a special config is found in the image and completely ignore the default entry during the selection. These devices can now use the variable DEVICE_DTS_CONFIG in their device image definition. Signed-off-by: Sven Eckelmann <sven@narfation.org>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 9ec3a84884..0f9ac0836c 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -118,6 +118,7 @@ define Build/fit
-D $(DEVICE_NAME) -o $@.its -k $@ \
$(if $(word 2,$(1)),-d $(word 2,$(1))) -C $(word 1,$(1)) \
-a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config@1") \
-A $(LINUX_KARCH) -v $(LINUX_VERSION)
PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
@mv $@.new $@