aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-12-17 19:27:02 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-17 19:44:45 +0100
commitb8271e9da041df5d3db2bb0d8e3ae6628fef13c5 (patch)
treecf83f22ba6653c0a2819f043bada56a6a455cf07 /include/image-commands.mk
parent5ae45dc7b30c928ad7aaf2d8a3b9b6d5eefb4fc2 (diff)
downloadupstream-b8271e9da041df5d3db2bb0d8e3ae6628fef13c5.tar.gz
upstream-b8271e9da041df5d3db2bb0d8e3ae6628fef13c5.tar.bz2
upstream-b8271e9da041df5d3db2bb0d8e3ae6628fef13c5.zip
image: remove duplicate cameo-factory
The function was accidentally added twice. Remove the duplicate. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk12
1 files changed, 0 insertions, 12 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 4e93115963..63539bad08 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -56,18 +56,6 @@ define Build/cameo-factory
mv $@.new $@
endef
-# blow up binary to given size and put a given string at its end:
-# cameo-factory <size[k]> <string>
-define Build/cameo-factory
- factory_stamp=$(word 2,$(1)); \
- ((reduced_size=$(subst k,*1024,$(word 1,$(1)))-$${#factory_stamp})); \
- ( \
- dd if=$@ bs=$$reduced_size conv=sync; \
- echo -n $$factory_stamp; \
- ) > $@.new && \
- mv $@.new $@
-endef
-
define Build/eva-image
$(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
mv $@.new $@