aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-17 21:47:16 +0100
committerMathias Kresin <dev@kresin.me>2018-12-17 23:21:26 +0100
commitffdce856e0c05616a033470f358b12ab0db8fde0 (patch)
treef21191571df0f4f4bd8566d128cf5e3aa50c79b1 /include/image-commands.mk
parent6263a9baa3b627ab8b996959975174934b60586d (diff)
downloadupstream-ffdce856e0c05616a033470f358b12ab0db8fde0.tar.gz
upstream-ffdce856e0c05616a033470f358b12ab0db8fde0.tar.bz2
upstream-ffdce856e0c05616a033470f358b12ab0db8fde0.zip
build: move append-string to image-commands.mk
Move it to image-commands.mk so that it can used by other targets. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 63539bad08..49138a216d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -102,6 +102,10 @@ define Build/append-squashfs-fakeroot-be
cat $@.fakesquashfs >> $@
endef
+define Build/append-string
+ echo -n $(1) >> $@
+endef
+
# append a fake/empty uImage header, to fool bootloaders rootfs integrity check
# for example
define Build/append-uImage-fakehdr